Adding Standards to your Planbook File

From Planbook for Mac Documentation
(Redirected from Add standards)
Jump to: navigation, search



Before you can track standards using Planbook, you have to enter in all of the standards that you're interested in applying to lessons. There are two methods for entering standards into your Planbook data file.

  1. Manually enter each standard
  2. Import each standard from a CSV or plist file

Instructions for each method are found below. Regardless of how you want to enter your standards, the process starts with opening Planbook's standards manager. This is done by selecting the Tools-->Standards Manager menu item.

Once you have opened the Standards Manager, you'll be presented with the window shown below.

Standards Manager without Standards Entered

Adding Standards Manually

Adding standards manually is an easy, if tedious, process. The process begins by pressing the Addstandardbutton.png button in the lower left corner. This will create a standard in your Planbook. The standard will be a substandard underneath the selected standard in the table view.

After creating a new standard, you'll notice a disclosure triangle next to the parent standard. This can be clicked to show or hide the sub-standards of that particular standard.

New standards are added with a default title and detail. The title and full text can easily be edited simply by clicking on the fields to the right and typing (or pasting from a webpage, word document, etc...) into the field as appropriate. Standards are updated as you type- there's no need to save or press enter to lock in your information.

After updating the title, the table view will reflect the new name immediately. As the table sorts alphabetically, the table will also resort immediately.

There is no limit to the depth of your standards- any standard you've entered can become a parent standard for other standards. The images below show the process of selecting a standard to be the parent standard, adding a new sub-standard and then revealing that standard.

Selecting the 11-12.WST.6 standard so it can be made into a parent standard
The Add Standard button has been pressed and the disclosure triangle is present, showing that 11-12.WST.6 is a parent standard now
After clicking the disclosure triangle, the new standard (which has been renamed) is revealed).

Removing Standards

If you add a standard by mistake, or just want to remove one of the standards you've entered, you can easily do this by selecting the standard you want to remove and pressing the Removestandardbutton.png button.

Please note that removing a standard will:

  • Remove all sub-standards of the selected standard.
  • Remove the standard (and all sub-standards) from any lesson to which they were attached

Adding Standards From a CSV File

The other method to add standards to your Planbook file is to import them from a spreadsheet program such as Apple's Numbers, Microsoft Excel or even Google Docs. Standards imported into Planbook via a CSV file must adhere to a very specific format. That format is described now.

Importing Standards (No Sub-Standards)

If you want to import a single layer of standards where there are no substandards, you must set up a two column spreadsheet. That spreadsheet must take the form:

Standard 1 Full TextStandard 1 Title
Standard 2 Full TextStandard 2 Title
Standard 3 Full TextStandard 3 Title

Please double check your spreadsheet to ensure that:

  • There are no headers in your file (don't label your columns or rows)
  • There are no empty columns to the right of your standards. Please select any extra columns to the right of your data and remove them.

Once you have your spreadsheet created, please see the section on converting your spreadsheet to a CSV format.

Importing Nested Standards

The Spreadsheet format you are required to replicate becomes more complicated if you are going to import nested standards. Rather than the two column spreadsheet described above, you must create a four column spreadsheet. The format of this spreadsheet should mimic:

Standard 1 Full TextStandard 1 Title
Standard 1 Full TextStandard 1 TitleStandard 1.a Full TextStandard 1.a Title
Standard 1 Full TextStandard 1 TitleStandard 1.b Full TextStandard 1.b Title
Standard 2 Full TextStandard 2 Title
Standard 2 Full TextStandard 2 TitleStandard 2.a Full TextStandard 2.a Title
Standard 2 Full TextStandard 2 TitleStandard 2.b Full TextStandard 2.b Title
Standard 2.b Full TextStandard 2.b TitleStandard 2.b.i Full TextStandard 2.b.i Title

After importing the standards listed above, a series of nested standards of the format shown below will be created.

  • Standard 1
    • Standard 1.a
    • Standard 1.b
  • Standard 2
    • Standard 2.a
    • Standard 2.b
      • Standard 2.b.i

Convert your Spreadsheet to a Comma-Separated-Value Format

Your standards cannot be imported directly from the default spreadsheet formats. You must export your spreadsheet as a comma-separated-value (CSV) file. This is a file format that is easily interchanged with other applications. To save/export your file in CSV format please choose the appropriate information for your spreadsheet program below:

  • In Microsoft Excel, after creating your spreadsheet please do a "Save As" operation and select "CSV" as the format. Once you do this CSV save, you will need to open the file in Apple's TextEdit Application (in your Applications folder) and do a "Save As" again, selecting UTF-8 as the encoding for the file
  • In Apple's Numbers application, after creating your spreadsheet, choose the File-->Export menu item. Choose a name, ensure that the CSV option is selected as well as the UTF-8 (Unicode) encoding. This will create a file that can be imported directly into a Planbook file.
  • In Google Docs, you can choose the File-->Download As-->CSV menu item to export your file as a CSV file. Choose the UTF-8 encoding where applicable.

For additional information about your spreadsheet application and exporting to CSV, select the appropriate link below

Importing your CSV File

Once you have your spreadsheet file converted to the correct CSV format, all that's left is to click the Importbutton.png and choose the file that you want to import. After importing, your standards will be available underneath the All Standards standard.

If you don't immediately see your standards, please make sure that you check for a disclosure triangle (Disctriangle.png). If you see one, please click it to reveal your standards.

Sharing Standards using the plist Format

Exporting Standards to a plist File

Once your standards are available in Planbook, you can easily share them with other teachers who might use the same standards. Planbook offers the ability to export standards (using the Exportbutton.png) into a shareable file format.

Clicking the Exportbutton.png will cause all of the standards in your Planbook data file (including their nesting) to be stored in a file created on your Desktop. Planbook will inform you of the name of this file.

This .plist file can be shared with any other Planbook for Mac user via email, thumb drive or any other file sharing mechanism.

Importing Standards from a plist File

If you have a .plist file containing standards, you can easily import that file using the Importbutton.png button.

If you don't immediately see your standards, please make sure that you check for a disclosure triangle (Disctriangle.png). If you see one, please click it to reveal your standards.

Personal tools